miércoles, 27 de diciembre de 2017

Whatsapp todavía da soporte a los usuarios de android 2.3 (Telegram no)

 

Hace un tiempo ya (lo que pasa que he tardado en ponerme manos a la obra en escribir la entrada en el blog) leí en xatakandroid que el soporte para Android 2.3.7 se iba a extender hasta 2020.
En realidad pone para Android 2.3.7 y versiones anteriores, lo que al autor de la página le resulta contradictorio. Lo que yo poenso es que dan soporte a la API 10 de Android, que es de la versión 2.3.3 para adelante. Ignoro si la API 9, esto es la versión un poco más antigua 2.3, tiene todavía soporte, sería cuestión de probarlo.

Yo hace algún tiempo tuve que dejar de dar soporte para Froyo y anteriores, porque los servicios de google play no estaban disponibles y hacía tiempo que google había decidido sacar algunos servicios, que estaban en librerías .jar independientes, para integrarlos. Los servicios de google play sólo estaban disponibles a partir de la gingerbread. Cuando eso ocurrió, google sacó un paquete de servicios de google play más limitados para que fuera compatible con la 2.2, pero decidí no dar soporte.


Empiezo a tener muchos problemas para soportar la versión 2.3 de android. Para empezar a principios de este año ya no hay versiones actualizadas de google play services, ahora me encuentro con que el material desing (esto es la librería de compatibilidad de interfaz de usuario), a partir del lanzamiento de oreo ya no están disponibles, así que el nuevo material design que saquen a partir de ahora ya no estará disponible.

Por su parte Telegram a principios de este año ha dejado de dar soporte a usuarios con Androdid 2.3, cosa lógica por otra parte, pero con ello se le escapa algo el mercado de usuarios que usarán la aplicación hasta que se compren nuevo móvil.


No hay comentarios:

Publicar un comentario